SPL-C ERROR – Please use the proper driver on Samsung CLP-310N printer

If you get this error written on the test page when using Ubuntu or any other Linux distribution, you should install the Samsung Unified Driver. I’ve followed the tutorial on http://ubuntuforums.org/showthread.php?t=341621 point II.c and then I’ve added the network printer as lpd:///PASSTHRU with Make and Model “Samsung CLP-310 Series (SPL-C)” (NOT Samsung CLP-310 Foomatic/foo2qpdl)

Leave a Reply

Your email address will not be published. Required fields are marked *